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VISION Data Reduction Guidelines 

 

How to access VISION data: 

• Log on to the analysis cluster at http://analysis.sns.gov and click Launch Session. 

Enter the username and password for your ORNL Resource Account (created at 

the ORNL Guest Portal). 

o Alternatively, there is a dedicated data analysis computer in the VISION 

hutch that can be used to access the analysis cluster. 

• Open the Caja file browser by clicking on the icon or on your home folder (see 

picture below). Data measured during the experiment is located in 

data/SNS/VIS/IPTS-XXXXX/shared/manualreduce, where XXXXX is the IPTS 

experiment number.  

o It can also be found in /SNS/VIS/IPTS-XXXXX/shared/manualreduce. 

o Data are listed by the run numbers 

 

 

Using Mantid Workbench: 

• Open up Mantid Workbench by clicking the Applications tab → Analysis → Mantid 

Workbench. This can also be done by entering the mantidworkbench command in 

the terminal window  

• A window will pop up. Set the default instrument to VISION.  

• Optional: Choose the default directory to save your data. Click the Manage User 

Directories button. In the Default Save Directory, enter the path that you want your 

reduced data to be saved. Press OK. 

o This window can be found later using File → Manage User Directories 

• The main Mantid Workbench window is displayed below.  

http://analysis.sns.gov/
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o The Algorithms window contains a list of algorithms that can be used to 

modify the data manually (scaling, unit conversions, loading files, saving 

data in different file formats, etc.).  

▪ For detailed information about the algorithms, click on Help → 

Algorithm Descriptions.  

o The Plots window will display plots generated from the data. 

o Toggling between the Algorithms window and the Plots window can be 

achieved using the Plots and Algorithms tabs located below the Algorithm 

and Plots Window.  

o The Workspaces window contains the data files. 

o The Script Window displays the python scripts used to reduce VISION data.  

Inelastic Data Reduction: 

• Python scripts are used to reduce the data at VISION.  

o The local and global parameters that are executed in the script are the same 

as the corresponding algorithms found in the Algorithm search bar.  

• To open a script, click on File → Open Script and navigate to 

/SNS/VIS/shared/VIS_users/scripts/. This contains a list of scripts used to reduce 

VISION data. Open vis_analysis.py. 

o Save a new copy of vis_analysis.py in a different directory. 

▪ We recommend saving this script in your experiment folder 

(data/SNS/VIS/IPTS-XXXXX/shared/manualreduce directory).  

• An example of the python script is shown below. Users should only need to modify 

the file below line 8. The following will explain the main sections that may need to 

be modified during the data reduction process. 

Algorithms and 

Plots Window 

Workspaces 

Script Window 
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o Line 13: Controls which type of files is read and reduced. For most 

situations, we will be using pc_weight = False to use the auto-reduced files. 

o Line 14: Controls whether the files generated are saved or not when the 

script is executed.  

▪ Save flag = 0 will not automatically save the processed data. These 

files will be loaded into the Workspaces in the Mantidplot window and 

can be saved later in the desired formats using the Algorithms tab.  

▪ Save flag = 1 will automatically save the processed data in .nxs and 

ascii format to the working directory.  

o Lines 16-20 define the global parameters. These parameters will be used 

unless a local parameter is defined specifically in the data block (further 

explained below).  

▪ Lines 16 and 17 control scaling and shifting of the data.  

▪ Line 18: Controls how the data is binned. This allows for finer or 

coarser energy binning across different energy transfer ranges.  

• The example shows a coarse bin size (0.015) between -2 –  5 

meV, a fine bin size (0.003) between 5 – 200 meV, and 

coarser again (0.005) for 200 – 1000 meV.  

▪ Line 19: Smooths the data. Use 0 for no smoothing and 3 or greater 

for smoothing.   

▪ Line 20: Outputs data in either meV or wavenumber (cm-1). 

o The data block (Lines 25 and 26) is where the specific data sets are loaded 

and modified.  

▪ Enter the run number for the data set that you want to reduce. 

• To load a single file, just enter the run number (‘40782’). 

• To combine a series of files, enter the run numbers separated 

by a comma (‘40782,40789,40792’) 
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• Long measurements are often split up into shorter runs, such 

as a two hour measurement that is split up into 4 different runs 

(30 minutes each). These runs will be given the same name, 

such as CaF2_6mm_PAC_can_10x20_slits_5K, but the run 

numbers will be different. To load and combine all these files, 

simply include a dash after the run number of the first file in 

the series (‘40782-‘) and the script will  find and combine these 

files with the same name. 

▪ Designate whether the data is a sample or a background 

measurement. 

• ‘s’ marks the data as a sample measurement.  

• ‘b’ marks the data as a background measurement, which is 

typically an empty can. The background will be subtracted 

from the sample measurement.  

• Note: once a background measurement is defined, any 

sample listed subsequently will be background subtracted 

using that dataset unless a new background is defined. 

o In the example below, line 26 will use line 25 for a 

background. A new background is defined in line 28 

and is now used for lines 29 and 30. 

 

▪ To correct the spectra for temperature, a Bose-Einstein factor can be 

applied. This is useful to compare datasets collected at different 

temperatures. To apply the correction, define the sample 

temperature by entering the number in kelvin units. The example 

(line 26) shows that the sample was measured at T = 5 K. 

▪ Local parameters can be defined for each measurement, which will 

override the global parameters. A list of how to define each local 

parameter is shown in Line 22. 

o Line 29: Performs the VISION data reduction algorithm.  

 

Example of VISION Inelastic Data Reduction: 

• The script on Page 3 will reduce the data for a LaB6 sample measured in a 6 mm 

diameter vanadium PAC can at 5 K.  

• To execute the script, click on the Green Play Button or press Crtl + Shift + Enter. 

• The Workspaces window is now populated with 5 different data sets.  
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o VIS_run#... is the background and sample data sets. 

o NBG_VIS_run#... is the sample measurement with the background 

subtracted. NBG stands for no background. 

o BOSE_VIS_run#... is the sample with a Bose temperature correction.  

o BOSE_NBG_VIS_run#... is the sample with both a Bose temperature 

correction and the background subtracted. 

• To plot the spectrum, right click on the desired workbook and click Plot → 

Spectrum.  

o A window pops up and asks which spectra numbers to plot. VISION data is 

divided into three data sets, numbered 0, 1, and 2. These numbers are at 

the end of the file name when plotted, as observed in the Legend in the 

spectra below.  

▪ sp-0: High Q data (backscattering detector banks) 

▪ sp-1: Low Q data (forward scattering detector banks) 

▪ sp-2: Average of both low and high Q data 

• The inelastic signal is very weak compared to the high intensity elastic peak 

centered at ΔE = 0 meV. Once the plot is generated, you will have to zoom in to 

observe the inelastic signal. The axes can be scaled by double clicking on the axis 

and changing the values in the dialog box. Likewise, you can click the magnifying 
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glass button to manually zoom into an area of the graph by drawing a box on the 

graph. A third way is to click the Options Menu button on the plot window.  

• For this example, we will just use the average of high and low Q data (sp-2) without 

Bose correction.  

• Plot the sample, background, and NBG sample on the same graph.  

o Once a graph is plotted, other data sets can be added by dragging and 

dropping a workspace onto the graph window.  

• Zooming in on the low energy transfer region (<100 meV), we can observe that (1) 

the data is rather noisy and (2) the background is over-subtracted. 

o First, we will increase the bin size and smooth the data to reduce the noise. 

Change lines 18 and 19 to the following values: 

o Binning and smoothing parameters are determined on a case-by-case 

basis. This depends on the statistics, how sharp or broad the features are 

in your data, what information you are looking for, etc. Try adjusting both of 

these parameters to determine what works best for your data. 

▪ If the bin size is too coarse or too heavily smoothed, the data will look 

good but subtle features will be washed out of the data. If you are 

interested in broad features, you can get away with this type of 

treatment.  

▪ You can also plot the error bars to better determine if features are 

real or an artifact of noise.  

o As observed, the data is now significantly cleaner. Next, we need to scale 

down the background to correct for the over-subtraction.  



7 
 

o The vanadium PAC cans produce a very small signal compared to most 

sample signals. Other sample cans (aluminum, steel, etc.) will produce 

more significant signals and need to be more carefully subtracted. Most of 

the signal from the vanadium can (green curve) consists of broad bands 

located below 40 meV. This is the region that you should focus on when 

subtracting the empty vanadium cell. 

▪ To correct the over-subtraction, change the local parameter scaley 

for the background data set to scale it to 0.9.  

o The background subtraction now looks reasonable in terms of intensity. The 

vibrational modes of the empty can also agree well with the features in the 

sample measurement, so the background measurement does not need to 

be shifted in energy transfer (shiftx).  

o Data scaling, background subtraction, and many other data manipulation 

procedures can also be performed in the Algorithms tab in Mantid, rather 

than using the python script. For example, these commands can be 

executed by typing Scale or Minus in the Algorithms search bar.  

 

Saving Mantid Projects and Ascii Data Files: 

▪ To save the Mantid project, go to File → Save Project As and define the path where 

you want to save it. Click OK to save.  

o This will save a mantid project file (.mantid) along with nexus (.nxs) files for 

each of the data sets in the Workspaces tab.  
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▪ To save data in ascii format, click on the Algorithms tab and enter SaveAscii in the 

search bar. Pick the workspace that you want to save. Define the path and filename 

for the save location. Pick which form of separator you would like to use (space, 

comma, etc.) Click Run. 

▪ A .dat file has now been saved in the directory. It is in XYE format (energy transfer, 

intensity, error). 

o The three data sets (sp-0, sp-1, sp-2) are listed consecutively in the file. 

They are separated by the number of the data set beginning with 0, as seen 

below. 

 

 

Diffraction (Elastic) Data Reduction: 

▪ The python script used for reducing diffraction data at VISION is located at 

/data/SNS/VIS/shared/VIS_users/scripts/vis_eed_analysis.py.  

o Again, we recommend saving a copy of this file to your experiment folder.  
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▪ The overall structure of the script is very similar to the inelastic data reduction script 

shown previously, but the calculation is different.  

▪ Line 23: Controls whether the unit for the data is reduced in terms of d-spacing, 

momentum transfer (Q), time of flight (TOF), or wavelength.  

o This can also be done manually using the ConvertUnits algorithm and by 

setting Emode to Elastic in the ConvertUnits Window. 

▪ Executing the above script will produce three workspaces: the background, 

sample, and sample with background subtracted. The diffraction datasets are 

labeled VIS_EED. 

o The same steps for background subtraction should be completed, as shown 

in the inelastic data reduction section above.  

▪ The resulting diffraction pattern is split into 6 different banks corresponding to the 

6 annular (90º) diffraction detectors.  

▪ To save data in GSAS format, use the Algorithm SaveGSS.  

▪ For Rietveld refinements, an instrument parameter file is needed for calibration 

with instrument specific values. It is best to consult the instrument staff for the 

correct file describing your experimental setup.  

o  However, some instrument parameter files are located at 

/data/SNS/VIS/shared/VIS_users/eed_instprm. 
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